Thursday, July 28, 2011

QTP Menu bar items missing

Very recently, I found a very weird QTP issue that all menu items went missing. I kept on trying all menu bar items but most of the items went missing. I thought my QTP 11 software got corrupt and I reinstalled it.

After a fresh installation, the same issue was there. I did a lot of hit and trials and finally got the solution. Sometimes the issue comes when we use RestoreLayout method from Automation Object Model. Then unpredictable errors may occur while the script execution is in process including these menu items missing from "File", "Edit", "View" menus etc.

The solution I got is to right click anywhere on the toolbar area, click Customize, choose toolbars tab and click on the Restore all button. This should definitely fix this.

Have questions on this article? Feel free to ask me in the comments section below.

If you like this post, I would suggest you to subscribe my RSS feed to have future articles delivered to your email address directly.


Weight Loss/ Life Coach said...

Thanks, had same thing happen today out of Blue on QTP 10.0

Anonymous said...

Thanks a lot.. Got my QTP menus options right:)

Eilyn Peña said...

You saved me from a nightmare, after install the Quick Test Pro Add-In the menu items were missing.
I applied this easy fix and it's solved.

Anonymous said...


Anonymous said...

Thanks! Saved me a few HOURS!!!

Anonymous said...

Yep! The solution worked for me as well.

Anonymous said...

Just happened to me too. Thanks for your solution! I was freaking out! LOL!

Anonymous said...

Thanks a lot Brother, You the best. God bless you.

Anonymous said...

You solution worked for me. Thank you so much.

Anonymous said...

life saver, thanks.